What’s Vulnerable › Vulnerabilities
CVE-2024-12385: WP Abstracts <= 2.7.2 - Cross-Site Request Forgery to Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-18 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Abstracts plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.7.2. This is due to missing nonce validation on the wpabstracts_load_status() and wpabstracts_delete_abstracts() functions. This makes it possible for unauthenticated attackers to inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Kevon Adonis WP Abstracts: before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: Kevon Adonis WP Abstracts 2.7.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-abstracts-manuscripts-manager/trunk/abstracts/abstracts.manage.php#L148
- https://plugins.trac.wordpress.org/browser/wp-abstracts-manuscripts-manager/trunk/abstracts/abstracts.manage.php#L205
- https://plugins.trac.wordpress.org/changeset/3223874/
- https://wordpress.org/plugins/wp-abstracts-manuscripts-manager/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/79af711e-d044-447e-9802-8be648a3843d?source=cve
Get alerted when CVE-2024-12385 or the next vulnerability affects your stack