What’s Vulnerable › Vulnerabilities
CVE-2024-12386: WP Abstracts <= 2.7.3 - Cross-Site Request Forgery to Arbitrary Account Deletion
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Abstracts plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.7.3. This is due to missing nonce validation on multiple functions. This makes it possible for unauthenticated attackers to delete arbitrary accounts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Kevon Adonis WP Abstracts: before 2.7.4 — fixed in 2.7.4
How to fix
Upgrade to a fixed version: Kevon Adonis WP Abstracts 2.7.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3238664/
- https://wordpress.org/plugins/wp-abstracts-manuscripts-manager/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/efd27466-f68e-4d8a-a1ec-90dbb6ff126b?source=cve
Get alerted when CVE-2024-12386 or the next vulnerability affects your stack