What’s Vulnerable › Vulnerabilities
CVE-2024-12393: Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2024-003
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Drupal Core allows Cross-Site Scripting (XSS).This issue affects Drupal Core: from 8.8.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.
Affected products
- Drupal: from 8.8.0 before 10.2.11; from 10.3.0 before 10.3.9; from 11.0.0 before 11.0.8 — fixed in 10.2.11, 10.3.9, 11.0.8
How to fix
Upgrade to a fixed version: Drupal 10.2.11, 10.3.9, 11.0.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12393 or the next vulnerability affects your stack