What’s Vulnerable › Vulnerabilities
CVE-2024-12400: Tourmaster < 5.3.5 - Reflected XSS
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The tourmaster WordPress plugin before 5.3.5 does not escape generated URLs before outputting them in attributes, leading to Reflected Cross-Site Scripting.
Affected products
- tourmaster: before 5.3.5 — fixed in 5.3.5
How to fix
Upgrade to a fixed version: tourmaster 5.3.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3542315c-93c3-41dd-a99e-02a38cfd58fb/
- https://wpscan.com/vulnerability/3542315c-93c3-41dd-a99e-02a38cfd58fb/
Get alerted when CVE-2024-12400 or the next vulnerability affects your stack