What’s Vulnerable › Vulnerabilities
CVE-2024-12409: Simple:Press Forum <= 6.10.11 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Simple:Press Forum plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 's' parameter in all versions up to, and including, 6.10.11 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- simplepress Simple:Press Forum: before 6.10.12 — fixed in 6.10.12
How to fix
Upgrade to a fixed version: simplepress Simple:Press Forum 6.10.12. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/simplepress/trunk/admin/panel-plugins/forms/spa-plugins-list-form.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3230289%40simplepress&new=3230289%40simplepress&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b9ebeb96-2f39-488e-aef6-d5af0a37c24a?source=cve
Get alerted when CVE-2024-12409 or the next vulnerability affects your stack