What’s Vulnerable › Vulnerabilities
CVE-2024-12414: Themify Store Locator <= 1.1.9 - Cross-Site Request Forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-352
Description
The Themify Store Locator plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.1.9. This is due to missing or incorrect nonce validation on the setting_page() function. This makes it possible for unauthenticated attackers to modify the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- themifyme Themify Store Locator: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: themifyme Themify Store Locator 1.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/themify-store-locator/tags/1.1.9/includes/init.php#L142
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3206624%40themify-store-locator&new=3206624%40themify-store-locator&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/287abdef-24de-4e1b-a673-59cd37411bf6?source=cve
Get alerted when CVE-2024-12414 or the next vulnerability affects your stack