What’s Vulnerable › Vulnerabilities
CVE-2024-12430
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-280
Description
An attacker who successfully exploited these vulnerabilities could cause enable command execution. A vulnerability exists in the AC500 V3 version mentioned. After successfully exploiting CVE-2024-12429 (directory traversal), a successfully authenticated attacker can inject arbitrary commands into a specifically crafted file, which then will be executed by root user. All AC500 V3 products (PM5xxx) with firmware version earlier than 3.8.0 are affected by this vulnerability.
Affected products
- ABB AC500 V3: before 3.8.0 — fixed in 3.8.0
How to fix
Upgrade to a fixed version: ABB AC500 V3 3.8.0. Check the vendor advisory for mitigations.
References
- https://search.abb.com/library/Download.aspx?DocumentID=3ADR011377&LanguageCode=en&DocumentPartId=&Action=Launch
- http://seclists.org/fulldisclosure/2025/Jan/5
Get alerted when CVE-2024-12430 or the next vulnerability affects your stack