What’s Vulnerable › Vulnerabilities
CVE-2024-12452: Ziggeo <= 3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ziggeo plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ziggeo_event' shortcode in all versions up to, and including, 3.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- oliverfriedmann Ziggeo: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: oliverfriedmann Ziggeo 3.1.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ziggeo/tags/3.1/core/events.php#L52
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3242184%40ziggeo&new=3242184%40ziggeo&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/be82095d-2b15-432e-a667-523286fa9629?source=cve
Get alerted when CVE-2024-12452 or the next vulnerability affects your stack