What’s Vulnerable › Vulnerabilities
CVE-2024-1246: Concrete CMS in version 9 before 9.2.5 is vulnerable to reflected XSS via the Image URL Import Feature
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Concrete CMS in version 9 before 9.2.5 is vulnerable to reflected XSS via the Image URL Import Feature due to insufficient validation of administrator provided data. A rogue administrator could inject malicious code when importing images, leading to the execution of the malicious code on the website user’s browser. The Concrete CMS Security team scored this 2 with CVSS v3 vector AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N. This does not affect Concrete versions prior to version 9.
Affected products
- Concrete CMS: from 9.0.0 before 9.2.5 — fixed in 9.2.5
How to fix
Upgrade to a fixed version: Concrete CMS 9.2.5. Check the vendor advisory for mitigations.
References
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/925-release-notes
- https://www.concretecms.org/about/project-news/security/2024-02-04-security-advisory
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/925-release-notes
- https://www.concretecms.org/about/project-news/security/2024-02-04-security-advisory
Get alerted when CVE-2024-1246 or the next vulnerability affects your stack