What’s Vulnerable › Vulnerabilities
CVE-2024-1247: Concrete CMS version 9 before 9.2.5 vulnerable to stored XSS via the Role Name field
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Concrete CMS version 9 before 9.2.5 is vulnerable to stored XSS via the Role Name field since there is insufficient validation of administrator provided data for that field. A rogue administrator could inject malicious code into the Role Name field which might be executed when users visit the affected page. The Concrete CMS Security team scored this 2 with CVSS v3 vector AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Concrete versions below 9 do not include group types so they are not affected by this vulnerability.
Affected products
- Concrete CMS: from 9.0.0 before 9.2.5 — fixed in 9.2.5
How to fix
Upgrade to a fixed version: Concrete CMS 9.2.5. Check the vendor advisory for mitigations.
References
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/925-release-notes
- https://www.concretecms.org/about/project-news/security/2024-02-04-security-advisory
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/925-release-notes
- https://www.concretecms.org/about/project-news/security/2024-02-04-security-advisory
Get alerted when CVE-2024-1247 or the next vulnerability affects your stack