What’s Vulnerable › Vulnerabilities
CVE-2024-12472: Post Duplicator <= 2.36 - Authenticated (Contributor+) Protected Post Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-11 · updated 2026-06-17
- Weakness: CWE-639
Description
The Post Duplicator plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 2.36 via the mtphr_duplicate_post() function due to insufficient restrictions on which posts can be duplicated. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from password protected, private, or draft posts that they should not have access to by duplicating the post.
Affected products
- metaphorcreations Post Duplicator: before 2.37 — fixed in 2.37
How to fix
Upgrade to a fixed version: metaphorcreations Post Duplicator 2.37. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3219375%40post-duplicator&new=3219375%40post-duplicator&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3071b2dc-9673-4e30-bd04-7404eb6a1ed9?source=cve
Get alerted when CVE-2024-12472 or the next vulnerability affects your stack