What’s Vulnerable › Vulnerabilities
CVE-2024-12475: WP Multi Store Locator <= 2.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Multi Store Locator plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPExperts.io WP Multistore Locator: before 2.4.6 — fixed in 2.4.6
How to fix
Upgrade to a fixed version: WPExperts.io WP Multistore Locator 2.4.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3207533/
- https://wordpress.org/plugins/wp-multi-store-locator/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/089406e7-4f6a-416b-9077-e17c44069300?source=cve
Get alerted when CVE-2024-12475 or the next vulnerability affects your stack