What’s Vulnerable › Vulnerabilities
CVE-2024-12525: Easy MLS Listings Import <= 2.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy MLS Listings Import plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'homeasap-featured-listings' shortcode in all versions up to, and including, 2.0.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- homeasap Easy MLS Listings Import: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: homeasap Easy MLS Listings Import 2.1.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3242350%40easy-mls-listings-import&new=3242350%40easy-mls-listings-import
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6351a40d-523d-4edb-acba-5cf048a1014f?source=cve
Get alerted when CVE-2024-12525 or the next vulnerability affects your stack