What’s Vulnerable › Vulnerabilities
CVE-2024-12539: Elasticsearch Incorrect Authorization
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-17 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered where improper authorization controls affected certain queries that could allow a malicious actor to circumvent Document Level Security in Elasticsearch and get access to documents that their roles would normally not allow.
Affected products
- Elasticsearch: from 8.16.0 before 8.16.2 — fixed in 8.16.2
How to fix
Upgrade to a fixed version: Elasticsearch 8.16.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12539 or the next vulnerability affects your stack