What’s Vulnerable › Vulnerabilities
CVE-2024-12560: Button Block – Get fully customizable & multi-functional buttons <= 1.1.5 - Authenticated (Contributor+) Post Disclosure via Post Duplication
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-200
Description
The Button Block – Get fully customizable & multi-functional buttons plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.1.5 via the 'btn_block_duplicate_post' function. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract potentially sensitive data from draft, scheduled (future), private, and password protected posts.
Affected products
- bPlugins Button Block: before 1.1.6 — fixed in 1.1.6
How to fix
Upgrade to a fixed version: bPlugins Button Block 1.1.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3208482/button-block
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ac55e988-2b41-459b-9ab1-e5f9fdca203f?source=cve
Get alerted when CVE-2024-12560 or the next vulnerability affects your stack