What’s Vulnerable › Vulnerabilities

CVE-2024-12570: Privilege Context Switching Error in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.7 prior to 17.4.6, from 17.5 prior to 17.5.4, and from 17.6 prior to 17.6.2. It may have been possible for an attacker with a victim's `CI_JOB_TOKEN` to obtain a GitLab session token belonging to the victim.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.4.6, 17.5.4, 17.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-12570 or the next vulnerability affects your stack