What’s Vulnerable › Vulnerabilities
CVE-2024-12581: Kadence Blocks <= 3.2.53 - Authenticated (Admin+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gutenberg Blocks with AI by Kadence WP – Page Builder Features plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.2.53 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- stellarwp Kadence Blocks — Page Builder Toolkit for Gutenberg Editor: before 3.2.54 — fixed in 3.2.54
How to fix
Upgrade to a fixed version: stellarwp Kadence Blocks — Page Builder Toolkit for Gutenberg Editor 3.2.54. Check the vendor advisory for mitigations.
References
- https://research.cleantalk.org/cve-2024-10637/
- https://wpscan.com/vulnerability/df688dcc-9617-4f58-a310-891bfaea3695/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/406f3eaf-44a7-4e32-a620-8799eb74742a?source=cve
Get alerted when CVE-2024-12581 or the next vulnerability affects your stack