What’s Vulnerable › Vulnerabilities
CVE-2024-12584: 140+ Widgets | Xpro Addons For Elementor – FREE <= 1.4.6.2 - Authenticated (Contributor+) Post Disclosure via Post Duplication
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-200
Description
The 140+ Widgets | Xpro Addons For Elementor – FREE plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.4.6.2 via the 'duplicate' function. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract potentially sensitive data from draft, scheduled (future), private, and password protected posts.
Affected products
- Xpro Addons — 140+ Widgets for Elementor: before 1.4.6.3 — fixed in 1.4.6.3
How to fix
Upgrade to a fixed version: Xpro Addons — 140+ Widgets for Elementor 1.4.6.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3212531/xpro-elementor-addons
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fa085bc0-af0b-4797-a10f-4d41b4988c02?source=cve
Get alerted when CVE-2024-12584 or the next vulnerability affects your stack