What’s Vulnerable › Vulnerabilities
CVE-2024-12597: HT Mega <= 2.7.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via block_css and inner_css
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'block_css' and 'inner_css' parameters in all versions up to, and including, 2.7.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder: before 2.7.7 — fixed in 2.7.7
How to fix
Upgrade to a fixed version: devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder 2.7.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3209697/ht-mega-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/17f12e75-0bb6-48ed-9ba2-17caab268d61?source=cve
Get alerted when CVE-2024-12597 or the next vulnerability affects your stack