What’s Vulnerable › Vulnerabilities
CVE-2024-12601: Calculated Fields Form <= 5.2.63 - Denial of Service
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-17 · updated 2026-06-17
- Weakness: CWE-400
Description
The Calculated Fields Form plugin for WordPress is vulnerable to Denial of Service in all versions up to, and including, 5.2.63. This is due to unlimited height and width parameters for CAPTCHA images. This makes it possible for unauthenticated attackers to send multiple requests with large values, resulting in slowing server resources if the server does not mitigate Denial of Service attacks.
Affected products
- codepeople Calculated Fields Form: before 5.2.64 — fixed in 5.2.64
How to fix
Upgrade to a fixed version: codepeople Calculated Fields Form 5.2.64. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/calculated-fields-form/trunk/captcha/captcha.php#L74
- https://plugins.trac.wordpress.org/browser/calculated-fields-form/trunk/captcha/captcha.php#L75
- https://plugins.trac.wordpress.org/changeset/3207826/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1eade2ed-9a75-4857-a2c5-a21e016e7029?source=cve
Get alerted when CVE-2024-12601 or the next vulnerability affects your stack