What’s Vulnerable › Vulnerabilities

CVE-2024-12619: Insufficient Granularity of Access Control in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.0 before 17.8.6, 17.9 before 17.9.3, and 17.10 before 17.10.1, allowing internal users to gain unauthorized access to internal projects.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.8.6, 17.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-12619 or the next vulnerability affects your stack