What’s Vulnerable › Vulnerabilities
CVE-2024-12650: Wago: Vulnerability in libwagosnmp
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-05 · updated 2026-06-17
- Weakness: CWE-252
Description
An attacker with low privileges can manipulate the requested memory size, causing the application to use an invalid memory area. This could lead to a crash of the application but it does not affected other applications.
Affected products
- WAGO CC100 0751-9x01: before 04.07.01 — fixed in 04.07.01
- WAGO Edge Controller 0752-8303/8000-0002: before 04.07.01 — fixed in 04.07.01
- WAGO PFC100 G1 0750-810x/xxxx-xxxx: before 3.10.11; before 04.07.01 — fixed in 04.07.01, 3.10.11
- WAGO PFC100 G2 0750-811x-xxxx-xxxx: before 04.07.01 — fixed in 04.07.01
- WAGO PFC200 G1 750-820x-xxx-xxx: before 3.10.11; before 04.07.01 — fixed in 04.07.01, 3.10.11
- WAGO PFC200 G2 750-821x-xxx-xxx: before 04.07.01 — fixed in 04.07.01
- WAGO TP600 0762-420x/8000-000x: before 04.07.01 — fixed in 04.07.01
- WAGO TP600 0762-430x/8000-000x: before 04.07.01 — fixed in 04.07.01
- WAGO TP600 0762-520x/8000-000x: before 04.07.01 — fixed in 04.07.01
- WAGO TP600 0762-530x/8000-000x: before 04.07.01 — fixed in 04.07.01
- WAGO TP600 0762-620x/8000-000x: before 04.07.01 — fixed in 04.07.01
- WAGO TP600 0762-630x/8000-000x: before 04.07.01 — fixed in 04.07.01
How to fix
Upgrade to a fixed version: WAGO CC100 0751-9x01 04.07.01; WAGO Edge Controller 0752-8303/8000-0002 04.07.01; WAGO PFC100 G1 0750-810x/xxxx-xxxx 04.07.01, 3.10.11; WAGO PFC100 G2 0750-811x-xxxx-xxxx 04.07.01; WAGO PFC200 G1 750-820x-xxx-xxx 04.07.01, 3.10.11; WAGO PFC200 G2 750-821x-xxx-xxx 04.07.01; WAGO TP600 0762-420x/8000-000x 04.07.01; WAGO TP600 0762-430x/8000-000x 04.07.01; WAGO TP600 0762-520x/8000-000x 04.07.01; WAGO TP600 0762-530x/8000-000x 04.07.01; WAGO TP600 0762-620x/8000-000x 04.07.01; WAGO TP600 0762-630x/8000-000x 04.07.01. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12650 or the next vulnerability affects your stack