What’s Vulnerable › Vulnerabilities
CVE-2024-12678: Nomad Allocations Vulnerable To Privilege Escalation Within A Namespace Using Unredacted Workload Identity Tokens
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-20 · updated 2026-06-17
- Weakness: CWE-266
Description
Nomad Community and Nomad Enterprise ("Nomad") allocations are vulnerable to privilege escalation within a namespace through unredacted workload identity tokens. This vulnerability, identified as CVE-2024-12678, is fixed in Nomad Community Edition 1.9.4 and Nomad Enterprise 1.9.4, 1.8.8, and 1.7.16.
Affected products
- HashiCorp Nomad Enterprise: from 1.4.0 before 1.7.16; from 1.4.0 before 1.9.4; from 1.8.0 before 1.8.8; from 1.9.0 before 1.9.4 — fixed in 1.7.16, 1.8.8, 1.9.4
How to fix
Upgrade to a fixed version: HashiCorp Nomad Enterprise 1.7.16, 1.8.8, 1.9.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12678 or the next vulnerability affects your stack