What’s Vulnerable › Vulnerabilities
CVE-2024-12680: Prisna GWT < 1.4.14 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Prisna GWT WordPress plugin before 1.4.14 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Prisna GWT – Google Website Translator: before 1.4.14 — fixed in 1.4.14
How to fix
Upgrade to a fixed version: Prisna GWT – Google Website Translator 1.4.14. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/28537fbc-3c2b-40c1-85f0-8b5f94eaad51/
- https://wpscan.com/vulnerability/28537fbc-3c2b-40c1-85f0-8b5f94eaad51/
Get alerted when CVE-2024-12680 or the next vulnerability affects your stack