What’s Vulnerable › Vulnerabilities
CVE-2024-12683: Smart Maintenance Mode < 1.5.2 - Admin+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Smart Maintenance Mode WordPress plugin before 1.5.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Smart Maintenance Mode: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: Smart Maintenance Mode 1.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12683 or the next vulnerability affects your stack