What’s Vulnerable › Vulnerabilities
CVE-2024-12729
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-94
Description
A post-auth code injection vulnerability in the User Portal allows authenticated users to execute code remotely in Sophos Firewall older than version 21.0 MR1 (21.0.1).
Affected products
- Sophos Firewall: before 21.0.1 — fixed in 21.0.1
How to fix
Upgrade to a fixed version: Sophos Firewall 21.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12729 or the next vulnerability affects your stack