What’s Vulnerable › Vulnerabilities
CVE-2024-12737: WP BASE Booking of Appointments, Services and Events < 5.0.0 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP BASE Booking of Appointments, Services and Events WordPress plugin before 5.0.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- WP BASE Booking of Appointments, Services and Events: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: WP BASE Booking of Appointments, Services and Events 5.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12737 or the next vulnerability affects your stack