What’s Vulnerable › Vulnerabilities
CVE-2024-1274: My Calendar < 3.4.24 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The My Calendar WordPress plugin before 3.4.24 does not sanitise and escape some parameters, which could allow users with a role as low as Subscriber to perform Cross-Site Scripting attacks (depending on the permissions set by the admin)
Affected products
- joedolson My Calendar: before 3.4.24 — fixed in 3.4.24
How to fix
Upgrade to a fixed version: joedolson My Calendar 3.4.24. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/91dba45b-9930-4bfb-a7bf-903c46864e9f/
- https://wpscan.com/vulnerability/91dba45b-9930-4bfb-a7bf-903c46864e9f/
Get alerted when CVE-2024-1274 or the next vulnerability affects your stack