What’s Vulnerable › Vulnerabilities
CVE-2024-12740: Dependency on Vulnerable Third-Party Component exposes Vulnerabilities in NI Vision Software
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-1395
Description
Vision related software from NI used a third-party library for image processing that exposes several vulnerabilities. These vulnerabilities may result in arbitrary code execution. Successful exploitation requires an attacker to get a user to open a specially crafted file.
Affected products
- NI Data Record AD: through 2.0
- NI FlexRIO: before 25.0 — fixed in 25.0
- NI FRC Game Tools: through 25.0
- NI-IMAQdx: through 23.1
- NI Vision Acquisition Software: through 23.1
- NI Vision Builder for Automated Inspection: 23.x
- NI Vision Development Module: through 24.1
How to fix
Upgrade to a fixed version: NI FlexRIO 25.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12740 or the next vulnerability affects your stack