What’s Vulnerable › Vulnerabilities
CVE-2024-12772: Ninja Tables < 5.0.17 - Admin+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-31 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ninja Tables WordPress plugin before 5.0.17 does not sanitize and escape a parameter before outputting it back in the page when importing a CSV, leading to a Cross Site Scripting vulnerability.
Affected products
- WPManageNinja LLC Ninja Tables: before 5.0.17 — fixed in 5.0.17
How to fix
Upgrade to a fixed version: WPManageNinja LLC Ninja Tables 5.0.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12772 or the next vulnerability affects your stack