What’s Vulnerable › Vulnerabilities
CVE-2024-12789: PbootCMS IndexController.php code injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-74
Description
A vulnerability was found in PbootCMS up to 3.2.3. It has been classified as critical. This affects an unknown part of the file apps/home/controller/IndexController.php. The manipulation of the argument tag leads to code injection. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.4 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- PbootCMS: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: PbootCMS 3.2.4. Check the vendor advisory for mitigations.
References
- https://gist.github.com/J1rrY-learn/8e52bf055fd1806ada81ae1ff25dd817
- https://vuldb.com/?ctiid.288969
- https://vuldb.com/?id.288969
- https://vuldb.com/?submit.465122
Get alerted when CVE-2024-12789 or the next vulnerability affects your stack