What’s Vulnerable › Vulnerabilities
CVE-2024-1279: Paid Memberships Pro < 2.12.9 - Contributor+ Arbitrary User Custom Field Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-11 · updated 2026-06-17
Description
The Paid Memberships Pro WordPress plugin before 2.12.9 does not prevent user with at least the contributor role from leaking other users' sensitive metadata.
Affected products
- Paid Memberships Pro: before 2.12.9 — fixed in 2.12.9
How to fix
Upgrade to a fixed version: Paid Memberships Pro 2.12.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4c537264-0c23-428e-9a11-7a9e74fb6b69/
- https://wpscan.com/vulnerability/4c537264-0c23-428e-9a11-7a9e74fb6b69/
Get alerted when CVE-2024-1279 or the next vulnerability affects your stack