What’s Vulnerable › Vulnerabilities
CVE-2024-12808: WP ERP | Complete HR solution with recruitment < 1.13.4 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting WordPress plugin before 1.13.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- weDevs WP ERP: before 1.13.4 — fixed in 1.13.4
How to fix
Upgrade to a fixed version: weDevs WP ERP 1.13.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f1f823f5-d0f1-45a5-85c2-60208d76366e/
- https://wpscan.com/vulnerability/f1f823f5-d0f1-45a5-85c2-60208d76366e/
Get alerted when CVE-2024-12808 or the next vulnerability affects your stack