What’s Vulnerable › Vulnerabilities
CVE-2024-12842: Emlog Pro user.php cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in Emlog Pro up to 2.4.1. It has been declared as problematic. This vulnerability affects unknown code of the file /admin/user.php. The manipulation of the argument keyword leads to cross site scripting. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used.
Affected products
- emlog: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: emlog 2.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/emlog/emlog/issues/305
- https://vuldb.com/?ctiid.289078
- https://vuldb.com/?id.289078
- https://github.com/emlog/emlog/issues/305
Get alerted when CVE-2024-12842 or the next vulnerability affects your stack