What’s Vulnerable › Vulnerabilities
CVE-2024-12855: AdForest - Classified Ads WordPress Theme <= 5.1.7 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Post/Attachment Deletion
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-862
Description
The AdForest theme for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several AJAX actions like 'sb_remove_ad' in all versions up to, and including, 5.1.7. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete posts, attachments and deactivate a license.
Affected products
- scriptsbundle AdForest: before 5.1.8 — fixed in 5.1.8
How to fix
Upgrade to a fixed version: scriptsbundle AdForest 5.1.8. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/adforest-classified-wordpress-theme/19481695
- https://www.wordfence.com/threat-intel/vulnerabilities/id/db7f5553-758b-47ab-8319-a549b73f4cfa?source=cve
Get alerted when CVE-2024-12855 or the next vulnerability affects your stack