What’s Vulnerable › Vulnerabilities
CVE-2024-12857: AdForest <= 5.1.8 - Authentication Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-288
Description
The AdForest theme for WordPress is vulnerable to authentication bypass in all versions up to, and including, 5.1.8. This is due to the plugin not properly verifying a user's identity prior to logging them in as that user. This makes it possible for unauthenticated attackers to authenticate as any user as long as they have configured OTP login by phone number.
Affected products
- scriptsbundle AdForest: before 5.1.9 — fixed in 5.1.9
How to fix
Upgrade to a fixed version: scriptsbundle AdForest 5.1.9. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/adforest-classified-wordpress-theme/19481695
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4ff3b4f1-dd36-43d0-b472-55a940907437?source=cve
Get alerted when CVE-2024-12857 or the next vulnerability affects your stack