What’s Vulnerable › Vulnerabilities
CVE-2024-12860: CarSpot – Dealership Wordpress Classified Theme <= 2.4.3 - Unauthenticated Arbitrary Password Reset/Account Takeover
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-620
Description
The CarSpot – Dealership Wordpress Classified Theme theme for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 2.4.3. This is due to the plugin not properly validating a token prior to updating a user's password. This makes it possible for unauthenticated attackers to change arbitrary user's passwords, including administrators, and leverage that to gain access to their account.
Affected products
- scriptsbundle CarSpot – Dealership Wordpress Classified Theme: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: scriptsbundle CarSpot – Dealership Wordpress Classified Theme 2.4.4. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/carspot-automotive-car-dealer-wordpress-classified-theme/20195539
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d1043dce-628f-485b-bc1c-b78938c2a6f5?source=cve
Get alerted when CVE-2024-12860 or the next vulnerability affects your stack