What’s Vulnerable › Vulnerabilities
CVE-2024-12878: Custom Block Builder – Lazy Blocks < 3.8.3 - Reflected XSS
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Custom Block Builder WordPress plugin before 3.8.3 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- Thedevoice Lazy Blocks: before 3.8.3 — fixed in 3.8.3
How to fix
Upgrade to a fixed version: Thedevoice Lazy Blocks 3.8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12878 or the next vulnerability affects your stack