What’s Vulnerable › Vulnerabilities
CVE-2024-12909: SQL Injection to RCE in run-llama/llama_index
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability in the FinanceChatLlamaPack of the run-llama/llama_index repository, versions up to v0.12.3, allows for SQL injection in the `run_sql_query` function of the `database_agent`. This vulnerability can be exploited by an attacker to inject arbitrary SQL queries, leading to remote code execution (RCE) through the use of PostgreSQL's large object functionality. The issue is fixed in version 0.3.0.
Affected products
- run-llama/llama_index: before 0.3.0 — fixed in 0.3.0
How to fix
Upgrade to a fixed version: run-llama/llama_index 0.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/commit/5d03c175476452db9b8abcdb7d5767dd7b310a75
- https://huntr.com/bounties/44e8177f-200a-4ba3-a12c-8bc21e313a3f
Get alerted when CVE-2024-12909 or the next vulnerability affects your stack