What’s Vulnerable › Vulnerabilities
CVE-2024-12910: Denial of Service in run-llama/llama_index
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-674
Description
A vulnerability in the `KnowledgeBaseWebReader` class of the run-llama/llama_index repository, version latest, allows an attacker to cause a Denial of Service (DoS) by controlling a URL variable to contain the root URL. This leads to infinite recursive calls to the `get_article_urls` method, exhausting system resources and potentially crashing the application.
Affected products
- run-llama/llama_index: before 0.12.9 — fixed in 0.12.9
How to fix
Upgrade to a fixed version: run-llama/llama_index 0.12.9. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/commit/159ce485a1168100bb219dc1b93133f1121579d9
- https://huntr.com/bounties/27883f22-35ff-49df-aaa5-05031c7d6ad8
- https://huntr.com/bounties/27883f22-35ff-49df-aaa5-05031c7d6ad8
Get alerted when CVE-2024-12910 or the next vulnerability affects your stack