What’s Vulnerable › Vulnerabilities
CVE-2024-12911: SQL Injection in run-llama/llama_index
- Severity: high (CVSS 7.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability in the `default_jsonalyzer` function of the `JSONalyzeQueryEngine` in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.
Affected products
- run-llama/llama_index: before 0.5.1 — fixed in 0.5.1
How to fix
Upgrade to a fixed version: run-llama/llama_index 0.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/commit/bf282074e20e7dafd5e2066137dcd4cd17c3fb9e
- https://huntr.com/bounties/095f9e67-311d-494c-99c5-5e61a0adb8f3
Get alerted when CVE-2024-12911 or the next vulnerability affects your stack