What’s Vulnerable › Vulnerabilities
CVE-2024-1292: WPB Show Core < 2.6 - Reflected XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPB Show Core WordPress plugin before 2.7 does not sanitise and escape some parameters before outputting them back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- wpb-show-core: before 2.7 — fixed in 2.7
How to fix
Upgrade to a fixed version: wpb-show-core 2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/56d4fc48-d0dc-4ac6-93cd-f64d4c3c5c07/
- https://wpscan.com/vulnerability/56d4fc48-d0dc-4ac6-93cd-f64d4c3c5c07/
Get alerted when CVE-2024-1292 or the next vulnerability affects your stack