What’s Vulnerable › Vulnerabilities
CVE-2024-13009: Eclipse Jetty GZIP buffer release
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-404
Description
In Eclipse Jetty versions 9.4.0 to 9.4.56 a buffer can be incorrectly released when confronted with a gzip error when inflating a request body. This can result in corrupted and/or inadvertent sharing of data between requests.
Affected products
- The Eclipse Foundation Eclipse Jetty: from 9.4.0 before 9.4.57 — fixed in 9.4.57
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse Jetty 9.4.57. Check the vendor advisory for mitigations.
References
- https://github.com/jetty/jetty.project/security/advisories/GHSA-q4rv-gq96-w7c5
- https://gitlab.eclipse.org/security/cve-assignement/-/issues/48
Get alerted when CVE-2024-13009 or the next vulnerability affects your stack