What’s Vulnerable › Vulnerabilities
CVE-2024-13026: Inadequate Encryption Strength Vulnerability in Roche Algo Edge
- Severity: medium (CVSS 6.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-17 · updated 2026-06-17
- Weakness: CWE-326
Description
A vulnerability exists in Algo Edge up to 2.1.1 - a previously used (legacy) component of navify® Algorithm Suite. The vulnerability impacts the authentication mechanism of this component and could allow an attacker with adjacent access to the laboratory network and the Algo Edge system to craft valid authentication tokens and access the component. Other components of navify® Algorithm Suite are not affected.
Affected products
- Roche Diagnostics Algorithm Suite: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Roche Diagnostics Algorithm Suite 2.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-13026 or the next vulnerability affects your stack