What’s Vulnerable › Vulnerabilities

CVE-2024-13041: Incorrect User Management in GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 16.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1. When a user is created via the SAML provider, the external groups setting overrides the external provider configuration. As a result, the user may not be marked as external thereby giving those users access to internal projects or groups.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.5.5, 17.6.3, 17.7.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-13041 or the next vulnerability affects your stack