What’s Vulnerable › Vulnerabilities
CVE-2024-13089: Authenticated RCE in update functionality in Guardian/CMC before 24.6.0
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS command injection vulnerability within the update functionality may allow an authenticated administrator to execute unauthorized arbitrary OS commands. Users with administrative privileges may upload update packages to upgrade the versions of Nozomi Networks Guardian and CMC. While these updates are signed and their signatures are validated prior to installation, an improper signature validation check has been identified. This issue could potentially enable users to execute commands remotely on the appliance, thereby impacting confidentiality, integrity, and availability.
Affected products
- Nozomi Networks CMC: before 24.6.0 — fixed in 24.6.0
- Nozomi Networks Guardian: before 24.6.0 — fixed in 24.6.0
How to fix
Upgrade to a fixed version: Nozomi Networks CMC 24.6.0; Nozomi Networks Guardian 24.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-13089 or the next vulnerability affects your stack