What’s Vulnerable › Vulnerabilities
CVE-2024-13091: WPBot Pro Wordpress Chatbot <= 13.5.4 - Unauthenticated Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-434
Description
The WPBot Pro Wordpress Chatbot plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'qcld_wpcfb_file_upload' function in all versions up to, and including, 13.5.4. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. Note: The exploit requires thee ChatBot Conversational Forms plugin and the Conversational Form Builder Pro addon plugin.
Affected products
- Wpbot Wpot: before 13.5.6 — fixed in 13.5.6
How to fix
Upgrade to a fixed version: Wpbot Wpot 13.5.6. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0f9b6979-2662-4d2f-9656-b880dd80832c?source=cve
- https://www.wpbot.pro/
Get alerted when CVE-2024-13091 or the next vulnerability affects your stack