What’s Vulnerable › Vulnerabilities
CVE-2024-1310: WooCommerce < 8.6 - Contributor+ Private/Draft Products Access
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-15 · updated 2026-07-20
Description
The WooCommerce WordPress plugin before 8.6 does not prevent users with at least the contributor role from leaking products they shouldn't have access to. (e.g. private, draft and trashed products)
Affected products
- Automattic Woocommerce: before 8.6.0 — fixed in 8.6.0
How to fix
Upgrade to a fixed version: Automattic Woocommerce 8.6.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a7735feb-876e-461c-9a56-ea6067faf277/
- https://wpscan.com/vulnerability/a7735feb-876e-461c-9a56-ea6067faf277/
Get alerted when CVE-2024-1310 or the next vulnerability affects your stack