What’s Vulnerable › Vulnerabilities
CVE-2024-1311: Brizy – Page Builder <= 2.4.40 - Authenticated (Contributor+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-434
Description
The Brizy – Page Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the storeImages function in all versions up to, and including, 2.4.40. This makes it possible for authenticated attackers, with contributor access or above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- themefusecom Brizy – Page Builder: before 2.4.41 — fixed in 2.4.41
How to fix
Upgrade to a fixed version: themefusecom Brizy – Page Builder 2.4.41. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/brizy/trunk/editor/zip/archiver.php#L254
- https://plugins.trac.wordpress.org/changeset/3034945/brizy/tags/2.4.41/editor/zip/archiver.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dc023c1b-7ec6-45b6-b50a-f0d823065843?source=cve
- https://plugins.trac.wordpress.org/browser/brizy/trunk/editor/zip/archiver.php#L254
- https://plugins.trac.wordpress.org/changeset/3034945/brizy/tags/2.4.41/editor/zip/archiver.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dc023c1b-7ec6-45b6-b50a-f0d823065843?source=cve
Get alerted when CVE-2024-1311 or the next vulnerability affects your stack