What’s Vulnerable › Vulnerabilities
CVE-2024-13128: LearnPress – WordPress LMS Plugin < 4.2.7.5.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses: before 4.2.7.5.1 — fixed in 4.2.7.5.1
How to fix
Upgrade to a fixed version: thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses 4.2.7.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1506a339-f85a-408a-8efa-ca83eb3b3ffb/
- https://wpscan.com/vulnerability/1506a339-f85a-408a-8efa-ca83eb3b3ffb/
Get alerted when CVE-2024-13128 or the next vulnerability affects your stack